QWC2 · CVE-2025-11183 · Package
FIX → 2025.8.14
QWC2, a web client for QGIS map servers, has a cross-site scripting flaw in its attribute table. An authorized user can plant arbitrary JavaScript that runs in other users' browsers.
first public Oct 13, 2025 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Teams that run a QWC2 web client built from the npm package at a version below 2025.8.14, where users with an account can view attribute tables. The sources do not describe a configuration that makes this safe, so treat any deployment below the fixed version as exposed. Deployments that only serve static builds from a fixed version are not affected.
Not affected if fixed-version
Who cares cwe-79, npm, qgis, qwc2, web-gis
qwc2 npm package, for example with npm ls qwc2.qwc2 entry in package.json and package-lock.json for a version below 2025.8.14.Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 < 2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page.
This page as .md · .json · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:N/R:X/V:X/RE:L/U:X
GitHub Advisory Database, CC-BY 4.0 · NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Upgrade to 2025.8.14
qwc2 2025.8.14