---
id: "CVE-2024-35059"
kind: "vulnerability"
aliases: ["CVE-2024-35059", "GHSA-jqff-8g2v-642h"]
title: "NASA AIT-Core vulnerable to remote code execution"
severity: "critical"
cvss: 9.8
epss: 0.00453
exploited: false
status: "open"
category: "package"
products: [{"name": "ait-core", "fixed": [], "affected": "<= 2.5.2", "ecosystem": "pypi"}, {"name": "nasa ait core", "fixed": [], "affected": "<= 2.5.2", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["ait-core", "cwe-319", "cwe-74", "package", "pypi", "python"]
not_affected_if: ["not-using-ait-core"]
published_at: "2024-05-21T19:15:10+00:00"
first_seen_at: "2026-10-26T21:16:46+00:00"
updated_at: "2026-10-26T21:20:32+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-jqff-8g2v-642h", "first_seen_at": "2026-10-26T21:16:46+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2024-35059", "first_seen_at": "2026-10-26T21:20:32+00:00"}]
---

# NASA AIT-Core vulnerable to remote code execution

NASA AIT-Core, a Python package, uses the pickle library in a way that lets an attacker execute arbitrary commands. The sources say the flaw affects version 2.5.2 and earlier, and the advisory rates it critical with a CVSS score of 9.8.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:ait-core affected <= 2.5.2 fixed ?
- vendor:nasa ait core affected <= 2.5.2 fixed ?

## How to check

- Run `pip show ait-core` and check whether the reported version is `2.5.2` or lower
- Search your code and dependencies for `ait-core` in requirements or lock files

## Fix

- Upgrade `ait-core` to a version newer than `2.5.2`; the fixed version is unknown from the sources
- Stop loading untrusted pickle data until the upgrade is done

## Timeline

- 2026-10-26T21:16:46+00:00 ghsa https://github.com/advisories/GHSA-jqff-8g2v-642h
- 2026-10-26T21:20:32+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2024-35059

## From the sources

An issue in the Pickle Python library of NASA AIT-Core v2.5.2 allows attackers to execute arbitrary commands.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
