{"id":"CVE-2024-35059","kind":"vulnerability","aliases":["CVE-2024-35059","GHSA-jqff-8g2v-642h"],"related":[],"title":"NASA AIT-Core vulnerable to remote code execution","description":"An issue in the Pickle Python library of NASA AIT-Core v2.5.2 allows attackers to execute arbitrary commands.","summary":"NASA AIT-Core, a Python package, uses the pickle library in a way that lets an attacker execute arbitrary commands. The sources say the flaw affects version 2.5.2 and earlier, and the advisory rates it critical with a CVSS score of 9.8.","severity":"critical","cvss":9.8,"epss":0.00453,"exploited":false,"exploited_at":null,"products":[{"name":"ait-core","fixed":[],"affected":"<= 2.5.2","ecosystem":"pypi"},{"name":"nasa ait core","fixed":[],"affected":"<= 2.5.2","ecosystem":"vendor"}],"ecosystems":["pypi","vendor"],"tags":["ait-core","cwe-319","cwe-74","package","pypi","python"],"not_affected_if":["not-using-ait-core"],"how_to_check":"- Run `pip show ait-core` and check whether the reported version is `2.5.2` or lower\n- Search your code and dependencies for `ait-core` in requirements or lock files","fix":"- Upgrade `ait-core` to a version newer than `2.5.2`; the fixed version is unknown from the sources\n- Stop loading untrusted pickle data until the upgrade is done","status":"open","published_at":"2024-05-21T19:15:10+00:00","first_seen_at":"2026-10-26T21:16:46+00:00","triaged_at":"2026-10-26T21:16:58+00:00","updated_at":"2026-10-26T21:20:32+00:00","category":"package","confidence":0.6,"triage":{"at":"2026-10-26T21:16:58Z","model":"claude-haiku-5-5","output":{"fix":"- Upgrade `ait-core` to a version newer than `2.5.2`; the fixed version is unknown from the sources\n- Stop loading untrusted pickle data until the upgrade is done","reach":"unknown","title":"NASA AIT-Core: pickle deserialization lets attackers run arbitrary commands","impact":"high","summary":"NASA AIT-Core, a Python package, uses the pickle library in a way that lets an attacker execute arbitrary commands. The sources say the flaw affects version 2.5.2 and earlier, and the advisory rates it critical with a CVSS score of 9.8.","category":"package","nicknames":[],"who_cares":["python","ait-core","pypi"],"confidence":0.6,"needs_auth":"unknown","worst_case":"Attacker runs arbitrary commands on the host running ait-core","analyst_note":"Sources do not name the fixed version or the exact entry point that reaches pickle; check the GHSA advisory at https://github.com/advisories/GHSA-jqff-8g2v-642h for the patched release and the triggering function.","how_to_check":"- Run `pip show ait-core` and check whether the reported version is `2.5.2` or lower\n- Search your code and dependencies for `ait-core` in requirements or lock files","needs_analyst":true,"not_affected_if":["not-using-ait-core"],"who_is_affected":"Teams that install the ait-core package and run versions 2.5.2 or lower are exposed. The sources do not say which features or data paths trigger the pickle load, so systems that use ait-core on untrusted input should be checked first. Teams without this package in their dependency tree can skip it.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"unknown"},"cost_usd":0.000634,"input_tokens":3302,"output_tokens":607,"severity_before":"critical"},"analyst_status":null,"analyst_note":null,"search":"'-2024':11A,19A '-319':31B '-35059':12A,20A '-74':33B '2.5.2':65B '642h':17A '8g2v':16A '9.8':79B 'advisori':70B 'affect':63B 'ait':3A,22A,25A,28B,39B,90C 'ait-cor':2A,27B,38B,89C 'ait-core':21A 'allow':93C 'arbitrari':56B,97C 'attack':54B,94C 'code':8A 'command':57B,98C 'core':4A,23A,26A,29B,40B,91C 'critic':73B 'cve':10A,18A 'cvss':76B 'cwe':30B,32B 'earlier':67B 'execut':9A,55B,96C 'flaw':62B 'ghsa':14A 'ghsa-jqff-8g2v-642h':13A 'issu':81C 'jqff':15A 'let':52B 'librari':47B,86C 'nasa':1A,24A,37B,88C 'packag':34B,43B 'pickl':46B,84C 'pypi':35B 'python':36B,42B,85C 'rate':71B 'remot':7A 'say':60B 'score':77B 'sourc':59B 'use':44B 'v2.5.2':92C 'version':64B 'vulner':5A 'way':50B","nicknames":[],"mitigations":[],"who_affected":"Teams that install the ait-core package and run versions 2.5.2 or lower are exposed. The sources do not say which features or data paths trigger the pickle load, so systems that use ait-core on untrusted input should be checked first. Teams without this package in their dependency tree can skip it.","tier":"B","verified":{},"analyst_revisit_at":null,"first_public_at":"2024-05-21T19:15:10+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvss_by":"GitHub","poc_count":0,"sources":[{"source":"ghsa","external_id":"GHSA-jqff-8g2v-642h","url":"https://github.com/advisories/GHSA-jqff-8g2v-642h","severity":"critical","published_at":"2024-05-21T21:30:27+00:00","modified_at":"2026-10-26T21:14:18+00:00","first_seen_at":"2026-10-26T21:16:46+00:00","fetched_at":"2026-10-26T21:16:46+00:00","note":null},{"source":"nvd","external_id":"CVE-2024-35059","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-35059","severity":null,"published_at":"2024-05-21T19:15:10+00:00","modified_at":"2026-06-17T07:34:19+00:00","first_seen_at":"2026-10-26T21:20:32+00:00","fetched_at":"2026-10-26T21:20:32+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}