---
id: "CVE-2024-23730"
kind: "vulnerability"
aliases: ["CVE-2024-23730", "GHSA-297x-2qf3-jrj3"]
title: "Unsafe yaml deserialization in llama-hub"
severity: "critical"
cvss: 9.8
epss: 0.01202
exploited: false
status: "open"
category: "ai-tooling"
products: [{"name": "llama-hub", "fixed": ["0.0.67"], "affected": "< 0.0.67", "ecosystem": "pypi"}, {"name": "llamahub", "fixed": ["0.0.67"], "affected": "< 0.0.67", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["ai-apps", "ai-tooling", "cwe-502", "llama-hub", "llamaindex", "python"]
not_affected_if: ["not-using-plugin-loaders", "trusted-input-only", "version-0.0.67-or-later"]
published_at: "2024-01-21T17:15:44+00:00"
first_seen_at: "2026-10-27T17:32:35+00:00"
updated_at: "2026-10-27T17:36:17+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-297x-2qf3-jrj3", "first_seen_at": "2026-10-27T17:32:35+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2024-23730", "first_seen_at": "2026-10-27T17:32:47+00:00"}]
---

# Unsafe yaml deserialization in llama-hub

LlamaHub's OpenAPI and ChatGPT plugin loaders parse YAML with an unsafe loader instead of safe_load. A crafted YAML document loaded by these plugins can make the process execute arbitrary code.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:llama-hub affected < 0.0.67 fixed 0.0.67
- vendor:llamahub affected < 0.0.67 fixed 0.0.67

## How to check

- Run `pip show llama-hub` and check whether the version is below `0.0.67`
- Search the codebase for `llama_hub` imports of the OpenAPI or ChatGPT plugin loaders
- Check whether the loaders are fed YAML from users or other untrusted sources

## Fix

- Upgrade `llama-hub` to `0.0.67` or later
- Until upgraded, do not load OpenAPI or ChatGPT plugin specs from untrusted sources

## Timeline

- 2026-10-27T17:32:35+00:00 ghsa https://github.com/advisories/GHSA-297x-2qf3-jrj3
- 2026-10-27T17:32:47+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2024-23730

## From the sources

The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
