---
id: "CVE-2024-2195"
kind: "vulnerability"
aliases: ["CVE-2024-2195", "GHSA-mxvw-cj37-8g2h"]
title: "Aim Web API vulnerable to Remote Code Execution"
severity: "critical"
cvss: 9.8
epss: 0.01815
exploited: false
status: "open"
category: "package"
products: [{"name": "aim", "fixed": [], "affected": ">= 3.0.0, <= 3.25.0", "ecosystem": "pypi"}, {"name": "aimstack aim", "fixed": [], "affected": ">= 3.0.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["aim", "cwe-94", "ml-experiment-tracking", "package", "python", "self-hosted"]
not_affected_if: ["local-only-binding", "no-web-server"]
published_at: "2024-04-10T17:15:54+00:00"
first_seen_at: "2026-10-27T15:13:25+00:00"
updated_at: "2026-10-27T15:32:59+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-mxvw-cj37-8g2h", "first_seen_at": "2026-10-27T15:13:25+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2024-2195", "first_seen_at": "2026-10-27T15:32:59+00:00"}]
---

# Aim Web API vulnerable to Remote Code Execution

The Aim experiment tracker's web API endpoint /api/runs/search/run/ evaluates the query parameter as code, so a remote request can execute arbitrary commands on the server. The advisory describes this as full system compromise, with versions 3.0.0 through 3.25.0 affected.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:aim affected >= 3.0.0, <= 3.25.0 fixed ?
- vendor:aimstack aim affected >= 3.0.0 fixed ?

## How to check

- Run `pip show aim` and compare the installed version against `3.25.0`
- Check whether the Aim web server is reachable from untrusted networks, for example on the port listed in your deployment config
- Search web server or access logs for requests to `/api/runs/search/run/`

## Fix

- Upgrade the `aim` package to a version above `3.25.0` (fixed version not confirmed in sources; check the GHSA advisory)
- Until upgraded, block external access to the Aim web server with a firewall or reverse proxy rule on `/api/runs/search/run/`

## Timeline

- 2026-10-27T15:13:25+00:00 ghsa https://github.com/advisories/GHSA-mxvw-cj37-8g2h
- 2026-10-27T15:32:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2024-2195

## From the sources

A critical Remote Code Execution (RCE) vulnerability was identified in the aimhubio/aim project, specifically within the `/api/runs/search/run/` endpoint, affecting versions >= 3.0.0. The vulnerability resides in the `run_search_api` function of the `aim/web/api/runs/views.py` file, where improper restriction of user access to the `RunView` object allows for the execution of arbitrary code via the `query` parameter. This issue enables attackers to execute arbitrary commands on the server, potentially leading to full system compromise.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
