---
id: "CVE-2024-10835"
kind: "vulnerability"
aliases: ["CVE-2024-10835", "GHSA-qccg-9m4q-xfm6"]
title: "DB-GPT is vulnerable to SQL Injection attacks from unauthenticated users"
severity: "critical"
cvss: 9.8
epss: 0.01183
exploited: false
status: "open"
category: "ai-tooling"
products: [{"name": "dbgpt", "fixed": ["0.7.1"], "affected": "< 0.7.1", "ecosystem": "pypi"}, {"name": "dbgpt db-gpt", "fixed": [], "affected": "= 0.6.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["ai-tooling", "cwe-89", "dbgpt", "pypi", "python", "self-hosted"]
not_affected_if: ["auth-required"]
published_at: "2025-03-20T10:15:20+00:00"
first_seen_at: "2026-10-27T16:30:45+00:00"
updated_at: "2026-10-27T16:33:07+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-qccg-9m4q-xfm6", "first_seen_at": "2026-10-27T16:30:45+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2024-10835", "first_seen_at": "2026-10-27T16:33:07+00:00"}]
---

# DB-GPT is vulnerable to SQL Injection attacks from unauthenticated users

DB-GPT's web API endpoint POST /api/v1/editor/sql/run runs arbitrary SQL with no access control. An attacker can use DuckDB SQL to write arbitrary files on the server, which can lead to remote code execution.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:dbgpt affected < 0.7.1 fixed 0.7.1
- vendor:dbgpt db-gpt affected = 0.6.0 fixed ?

## How to check

- Check the installed version with `pip show dbgpt` and look for anything below `0.7.1`.
- Check whether the web server is reachable from untrusted networks and whether `/api/v1/editor/sql/run` responds.

## Fix

- Upgrade the `dbgpt` PyPI package to `0.7.1` or later.
- Until upgraded, block `/api/v1/editor/sql/run` at the reverse proxy or firewall.

## Timeline

- 2026-10-27T16:30:45+00:00 ghsa https://github.com/advisories/GHSA-qccg-9m4q-xfm6
- 2026-10-27T16:33:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2024-10835

## From the sources

In eosphoros-ai/db-gpt version v0.6.0, the web API `POST /api/v1/editor/sql/run` allows execution of arbitrary SQL queries without any access control. This vulnerability can be exploited by attackers to perform Arbitrary File Write using DuckDB SQL, enabling them to write arbitrary files to the victim's file system. This can potentially lead to Remote Code Execution (RCE).

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
