---
id: "CVE-2023-49657"
kind: "vulnerability"
aliases: ["CVE-2023-49657", "GHSA-rwhh-6x83-84v6"]
title: "Cross-site Scripting in Apache superset"
severity: "critical"
cvss: 9.6
epss: 0.00837
exploited: false
status: "open"
category: "package"
products: [{"name": "apache-superset", "fixed": ["3.0.3"], "affected": "< 3.0.3", "ecosystem": "pypi"}, {"name": "apache superset", "fixed": ["3.0.3"], "affected": "< 3.0.3", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["apache-superset", "cwe-79", "package", "python", "self-hosted"]
not_affected_if: ["fixed-version", "read-only-users"]
published_at: "2024-01-23T15:15:11+00:00"
first_seen_at: "2026-10-27T15:18:30+00:00"
updated_at: "2026-10-27T15:32:59+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-rwhh-6x83-84v6", "first_seen_at": "2026-10-27T15:18:30+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2023-49657", "first_seen_at": "2026-10-27T15:32:59+00:00"}]
---

# Cross-site Scripting in Apache superset

Apache Superset before 3.0.3 lets a user with chart or dashboard create/update permission store a script or crafted HTML snippet that runs in other users' browsers. An attacker can act as the victim inside Superset, such as reading or changing data the victim can see.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:apache-superset affected < 3.0.3 fixed 3.0.3
- vendor:apache superset affected < 3.0.3 fixed 3.0.3

## How to check

- Check the installed version: `pip show apache-superset`, and confirm it is below `3.0.3`.
- On 2.x, check whether `TALISMAN_CONFIG` in `superset_config.py` sets the content_security_policy shown in the advisory.

## Fix

- Upgrade `apache-superset` to `3.0.3` or later.
- On 2.x, where an upgrade is not possible, apply the `TALISMAN_CONFIG` content security policy from the advisory (the sample in the source has broken quoting and must be corrected before use).

## Timeline

- 2026-10-27T15:18:30+00:00 ghsa https://github.com/advisories/GHSA-rwhh-6x83-84v6
- 2026-10-27T15:32:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2023-49657

## From the sources

A stored cross-site scripting (XSS) vulnerability exists in Apache Superset before 3.0.3. An authenticated attacker with create/update permissions on charts or dashboards could store a script or add a specific HTML snippet that would act as a stored XSS.

For 2.X versions, users should change their config to include:

TALISMAN_CONFIG = {
    "content_security_policy": {
        "base-uri": ["'self'"],
        "default-src": ["'self'"],
        "img-src": ["'self'", "blob:", "data:"],
        "worker-src": ["'self'", "blob:"],
        "connect-src": [
            "'self'",
            " https://api.mapbox.com" https://api.mapbox.com" ;,
            " https://events.mapbox.com" https://events.mapbox.com" ;,
        ],
        "object-src": "'none'",
        "style-src": [
            "'self'",
            "'unsafe-inline'",
        ],
        "script-src": ["'self'", "'strict-dynamic'"],
    },
    "content_security_policy_nonce_in": ["script-src"],
    "force_https": False,
    "session_cookie_secure": False,
}

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
