{"id":"CVE-2023-28706","kind":"vulnerability","aliases":["CVE-2023-28706","GHSA-5cvg-9pp5-mxcj"],"related":[],"title":"Apache Airflow Hive Provider vulnerable to code injection","description":"Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 6.0.0.","summary":"The Apache Airflow Hive provider builds code from input it does not properly control, so crafted input can make it generate and run attacker-chosen code. An attacker who can reach that input path can run code in the Airflow worker or scheduler context.","severity":"critical","cvss":9.8,"epss":0.02765,"exploited":false,"exploited_at":null,"products":[{"name":"apache-airflow-providers-apache-hive","fixed":["6.0.0"],"affected":"< 6.0.0","ecosystem":"pypi"},{"name":"apache airflow hive provider","fixed":["6.0.0"],"affected":"< 6.0.0","ecosystem":"vendor"}],"ecosystems":["pypi","vendor"],"tags":["apache-airflow","cwe-94","data-pipelines","package","python","self-hosted"],"not_affected_if":["hive-provider-not-installed","provider-6.0.0-or-later"],"how_to_check":"- Run `pip show apache-airflow-providers-apache-hive` and confirm the installed version is below `6.0.0`.\n- Check the environment with `pip freeze | grep apache-airflow-providers-apache-hive`.","fix":"- Upgrade `apache-airflow-providers-apache-hive` to `6.0.0` or later.\n- Rebuild Airflow images or virtualenvs so the fixed provider is what runs.","status":"open","published_at":"2023-04-07T15:15:08+00:00","first_seen_at":"2026-10-26T21:11:45+00:00","triaged_at":"2026-10-26T21:12:40+00:00","updated_at":"2026-10-26T21:20:32+00:00","category":"package","confidence":0.6,"triage":{"at":"2026-10-26T21:12:40Z","model":"claude-haiku-5-5","output":{"fix":"- Upgrade `apache-airflow-providers-apache-hive` to `6.0.0` or later.\n- Rebuild Airflow images or virtualenvs so the fixed provider is what runs.","reach":"unknown","title":"Apache Airflow Hive provider: code injection lets crafted input run code","impact":"high","summary":"The Apache Airflow Hive provider builds code from input it does not properly control, so crafted input can make it generate and run attacker-chosen code. An attacker who can reach that input path can run code in the Airflow worker or scheduler context.","category":"package","nicknames":[],"who_cares":["apache-airflow","python","self-hosted","data-pipelines"],"confidence":0.6,"needs_auth":"unknown","worst_case":"Attacker-chosen code runs in the Airflow process context.","analyst_note":"Confirm the exact attack input and required privileges from https://github.com/advisories/GHSA-5cvg-9pp5-mxcj and the ASF advisory.","how_to_check":"- Run `pip show apache-airflow-providers-apache-hive` and confirm the installed version is below `6.0.0`.\n- Check the environment with `pip freeze | grep apache-airflow-providers-apache-hive`.","needs_analyst":true,"not_affected_if":["hive-provider-not-installed","provider-6.0.0-or-later"],"who_is_affected":"Teams running Apache Airflow with the Hive provider installed below 6.0.0 are exposed, since the flaw sits in code that Airflow loads when DAGs use Hive operators or hooks. Deployments without the Hive provider installed, or already on 6.0.0 or later, can skip it. The sources do not describe the exact input path, so whether a given DAG setup is reachable from outside is unknown.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"critical"},"cost_usd":0.00066,"input_tokens":3320,"output_tokens":655,"severity_before":"critical"},"analyst_status":null,"analyst_note":null,"search":"'-2023':10A,18A '-28706':11A,19A '-94':34B '5cvg':14A '6.0.0':112C '9pp5':15A 'affect':106C 'airflow':2A,22A,27A,32B,45B,83B,102C,108C 'apach':1A,31B,44B,98C,101C,107C 'apache':21A,24A,26A 'apache-airflow':30B 'apache-airflow-providers-apache-hive':20A 'attack':67B,71B 'attacker-chosen':66B 'build':48B 'chosen':68B 'code':7A,49B,69B,80B,93C,94C 'context':87B 'control':56B,89C 'craft':58B 'cve':9A,17A 'cwe':33B 'data':36B 'data-pipelin':35B 'foundat':100C 'generat':63B,91C 'ghsa':13A 'ghsa-5cvg-9pp5-mxcj':12A 'hive':3A,25A,28A,46B,103C,109C 'host':42B 'improp':88C 'inject':8A,95C 'input':51B,59B,76B 'issu':105C 'make':61B 'mxcj':16A 'packag':38B 'path':77B 'pipelin':37B 'proper':55B 'provid':4A,47B,110C 'provider':29A 'provider.this':104C 'providers':23A 'python':39B 'reach':74B 'run':65B,79B 'schedul':86B 'self':41B 'self-host':40B 'softwar':99C 'vulner':5A,96C 'worker':84B","nicknames":[],"mitigations":[],"who_affected":"Teams running Apache Airflow with the Hive provider installed below 6.0.0 are exposed, since the flaw sits in code that Airflow loads when DAGs use Hive operators or hooks. Deployments without the Hive provider installed, or already on 6.0.0 or later, can skip it. The sources do not describe the exact input path, so whether a given DAG setup is reachable from outside is unknown.","tier":"B","verified":{},"analyst_revisit_at":null,"first_public_at":"2023-04-07T15:15:08+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvss_by":"GitHub","poc_count":0,"sources":[{"source":"ghsa","external_id":"GHSA-5cvg-9pp5-mxcj","url":"https://github.com/advisories/GHSA-5cvg-9pp5-mxcj","severity":"critical","published_at":"2023-04-07T15:30:38+00:00","modified_at":"2026-10-26T21:10:32+00:00","first_seen_at":"2026-10-26T21:11:45+00:00","fetched_at":"2026-10-26T21:11:45+00:00","note":null},{"source":"nvd","external_id":"CVE-2023-28706","url":"https://nvd.nist.gov/vuln/detail/CVE-2023-28706","severity":null,"published_at":"2023-04-07T15:15:08+00:00","modified_at":"2026-06-17T05:48:36+00:00","first_seen_at":"2026-10-26T21:20:32+00:00","fetched_at":"2026-10-26T21:20:32+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}