---
id: "CVE-2023-25696"
kind: "vulnerability"
aliases: ["CVE-2023-25696", "GHSA-9mwf-mw74-9cv5"]
title: "Apache Airflow Hive Provider Improper Input Validation vulnerability"
severity: "critical"
cvss: 9.8
epss: 0.01982
exploited: false
status: "open"
category: "package"
products: [{"name": "apache-airflow-providers-apache-hive", "fixed": ["5.1.3"], "affected": "< 5.1.3", "ecosystem": "pypi"}, {"name": "apache apache-airflow-providers-apache-hive", "fixed": ["5.1.3"], "affected": "< 5.1.3", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["apache-airflow", "cwe-20", "hive", "package", "python"]
not_affected_if: ["hive-provider-not-installed", "version-5.1.3-or-later"]
published_at: "2023-02-24T12:15:30+00:00"
first_seen_at: "2026-10-26T21:11:45+00:00"
updated_at: "2026-10-26T21:20:32+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-9mwf-mw74-9cv5", "first_seen_at": "2026-10-26T21:11:45+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2023-25696", "first_seen_at": "2026-10-26T21:20:32+00:00"}]
---

# Apache Airflow Hive Provider Improper Input Validation vulnerability

The Apache Airflow Hive provider does not validate some input properly, tracked as CVE-2023-25696 and rated critical (CVSS 9.8). The sources do not describe what an attacker can do beyond that rating.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:apache-airflow-providers-apache-hive affected < 5.1.3 fixed 5.1.3
- vendor:apache apache-airflow-providers-apache-hive affected < 5.1.3 fixed 5.1.3

## How to check

- Run `pip show apache-airflow-providers-apache-hive` and check the Version line; anything below `5.1.3` is affected.
- Run `pip freeze | grep apache-airflow-providers-apache-hive` in each Airflow environment, including workers and images.

## Fix

- Upgrade apache-airflow-providers-apache-hive to `5.1.3` or later.
- Rebuild Airflow images and workers so the fixed version is in every environment.

## Timeline

- 2026-10-26T21:11:45+00:00 ghsa https://github.com/advisories/GHSA-9mwf-mw74-9cv5
- 2026-10-26T21:20:32+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2023-25696

## From the sources

Improper Input Validation vulnerability in the Apache Airflow Hive Provider.

This issue affects Apache Airflow Hive Provider versions before 5.1.3.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
