---
id: "CVE-2023-22884"
kind: "vulnerability"
aliases: ["CVE-2023-22884", "GHSA-c732-xvv8-g94c"]
title: "Command Injection in Apache Airflow and Apache Airflow MySQL Provider"
severity: "critical"
cvss: 9.8
epss: 0.11082
exploited: false
status: "open"
category: "package"
products: [{"name": "apache-airflow", "fixed": ["2.5.1"], "affected": "< 2.5.1", "ecosystem": "pypi"}, {"name": "apache-airflow-providers-mysql", "fixed": ["4.0.0"], "affected": "< 4.0.0", "ecosystem": "pypi"}, {"name": "apache airflow", "fixed": ["2.5.1"], "affected": "< 2.5.1", "ecosystem": "vendor"}, {"name": "apache apache-airflow-providers-mysql", "fixed": ["4.0.0"], "affected": "< 4.0.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["apache-airflow", "cwe-77", "data-pipelines", "package", "python", "self-hosted"]
not_affected_if: ["fixed-version"]
published_at: "2023-01-21T14:15:10+00:00"
first_seen_at: "2026-10-27T15:13:25+00:00"
updated_at: "2026-10-27T15:32:59+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-c732-xvv8-g94c", "first_seen_at": "2026-10-27T15:13:25+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2023-22884", "first_seen_at": "2026-10-27T15:32:59+00:00"}]
---

# Command Injection in Apache Airflow and Apache Airflow MySQL Provider

Apache Airflow and its MySQL provider mishandle special characters in a command, so crafted input can inject operating system commands. An attacker who can influence that input can run commands as the Airflow process.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:apache-airflow affected < 2.5.1 fixed 2.5.1
- pypi:apache-airflow-providers-mysql affected < 4.0.0 fixed 4.0.0
- vendor:apache airflow affected < 2.5.1 fixed 2.5.1
- vendor:apache apache-airflow-providers-mysql affected < 4.0.0 fixed 4.0.0

## How to check

- Run `pip show apache-airflow` and confirm the version is below `2.5.1`
- Run `pip show apache-airflow-providers-mysql` and confirm the version is below `4.0.0`

## Fix

- Upgrade `apache-airflow` to `2.5.1` or later
- Upgrade `apache-airflow-providers-mysql` to `4.0.0` or later

## Timeline

- 2026-10-27T15:13:25+00:00 ghsa https://github.com/advisories/GHSA-c732-xvv8-g94c
- 2026-10-27T15:32:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2023-22884

## From the sources

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
