---
id: "CVE-2022-46421"
kind: "vulnerability"
aliases: ["CVE-2022-46421", "GHSA-rc58-qr9j-cpgw"]
title: "Apache Airflow Hive Provider vulnerable to Command Injection"
severity: "critical"
cvss: 9.8
epss: 0.03286
exploited: false
status: "open"
category: "package"
products: [{"name": "apache-airflow-providers-apache-hive", "fixed": ["5.0.0"], "affected": "< 5.0.0", "ecosystem": "pypi"}, {"name": "apache apache-airflow-providers-apache-hive", "fixed": ["5.0.0"], "affected": "< 5.0.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["airflow", "cwe-77", "data-pipelines", "hive", "package", "python"]
not_affected_if: ["hive-provider-not-installed", "version-5.0.0-or-later"]
published_at: "2022-12-20T11:15:09+00:00"
first_seen_at: "2026-10-26T21:21:58+00:00"
updated_at: "2026-10-26T21:55:22+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-rc58-qr9j-cpgw", "first_seen_at": "2026-10-26T21:21:58+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2022-46421", "first_seen_at": "2026-10-26T21:55:22+00:00"}]
---

# Apache Airflow Hive Provider vulnerable to Command Injection

The Apache Airflow Hive provider builds shell commands from unsanitized input, so attacker-controlled values can inject extra commands. An attacker who can influence those inputs can run arbitrary commands on the Airflow worker.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:apache-airflow-providers-apache-hive affected < 5.0.0 fixed 5.0.0
- vendor:apache apache-airflow-providers-apache-hive affected < 5.0.0 fixed 5.0.0

## How to check

- Run `pip show apache-airflow-providers-apache-hive` and check whether the version is below `5.0.0`
- Check whether DAGs or connections pass user-controlled values into Hive operators or hooks

## Fix

- Upgrade `apache-airflow-providers-apache-hive` to `5.0.0` or later

## Timeline

- 2026-10-26T21:21:58+00:00 ghsa https://github.com/advisories/GHSA-rc58-qr9j-cpgw
- 2026-10-26T21:55:22+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2022-46421

## From the sources

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 5.0.0.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
