Live › vulnerability › CVE-2022-38649
Go to dashboardApache Airflow's Pinot Provider and core versions before 2.3.0 let an attacker control commands executed in the task execution context, without needing write access to DAG files. An attacker who can influence those inputs can run arbitrary operating system commands on the Airflow worker.
Summary written from the sources below. Check the originals before acting.
First seen by InfraStack 2026-10-26 21:16 UTC, 0h before NVD. All times on this page are UTC.
Teams running Apache Airflow below 2.3.0, or any Airflow install that has the Apache Pinot provider below 4.0.0 installed. The sources say exposure depends on the task execution path reaching the vulnerable code, so teams with no Pinot provider on pre-2.3.0 Airflow should still upgrade but are less exposed. Teams on Airflow 2.3.0+ with Pinot provider 4.0.0 are not affected.
| Product | Ecosystem | Affected | Fixed in |
|---|---|---|---|
| apache-airflow | pypi | < 2.3.0 | 2.3.0 |
| apache airflow | vendor | < 2.3.0 | 2.3.0 |
| apache apache-airflow-providers-apache-pinot | vendor | < 4.0.0 | 4.0.0 |
pip show apache-airflow and confirm the version is below 2.3.0.pip show apache-airflow-providers-apache-pinot and check whether it is installed and below 4.0.0.apache-airflow to 2.3.0 or later.apache-airflow-providers-apache-pinot version 4.0.0 or later, even on Airflow 2.3.0+, since the fix must be installed manually.Each row is the first time that source carried this signal. The analyst’s rows are its own findings.
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pinot Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Apache Airflow Pinot Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Apache Airflow Pinot Provider is installed (Apache Airflow Pinot Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pinot Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.
This page as .md · .json · in your agent: get_signal("CVE-2022-38649")
GitHub Advisory Database, CC-BY 4.0 · NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.