---
id: "CVE-2022-30765"
kind: "vulnerability"
aliases: ["CVE-2022-30765", "GHSA-8ppf-x4gr-2x7g"]
title: "SQL injection in calibreweb"
severity: "critical"
cvss: 9.8
epss: 0.01207
exploited: false
status: "open"
category: "package"
products: [{"name": "calibreweb", "fixed": ["0.6.18"], "affected": "< 0.6.18", "ecosystem": "pypi"}, {"name": "janeczku calibre-web", "fixed": [], "affected": "= 0.6.18", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["calibreweb", "cwe-89", "package", "python", "self-hosted"]
not_affected_if: ["version-0.6.18-or-later"]
published_at: "2022-05-16T02:15:06+00:00"
first_seen_at: "2026-10-27T16:20:27+00:00"
updated_at: "2026-10-27T16:33:08+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-8ppf-x4gr-2x7g", "first_seen_at": "2026-10-27T16:20:27+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2022-30765", "first_seen_at": "2026-10-27T16:33:08+00:00"}]
---

# SQL injection in calibreweb

Calibre-Web versions before 0.6.18 let an attacker inject SQL through a user table query. The attacker can read or change the application's database contents.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:calibreweb affected < 0.6.18 fixed 0.6.18
- vendor:janeczku calibre-web affected = 0.6.18 fixed ?

## How to check

- Run `pip show calibreweb` and confirm the version is below `0.6.18`
- Check the installed version with `pip freeze | grep -i calibreweb`

## Fix

- Upgrade the pypi package `calibreweb` to `0.6.18` or later

## Timeline

- 2026-10-27T16:20:27+00:00 ghsa https://github.com/advisories/GHSA-8ppf-x4gr-2x7g
- 2026-10-27T16:33:08+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2022-30765

## From the sources

Calibre-Web before 0.6.18 allows user table SQL Injection.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
