---
id: "CVE-2018-1000226"
kind: "vulnerability"
aliases: ["CVE-2018-1000226", "GHSA-f88q-22g8-frcg"]
title: "Cobbler Improper Validation of Security Tokens"
severity: "critical"
cvss: 9.8
epss: 0.12584
exploited: false
status: "open"
category: "package"
products: [{"name": "cobbler", "fixed": ["3.0.0"], "affected": "<= 2.6.11", "ecosystem": "pypi"}, {"name": "cobblerd cobbler", "fixed": [], "affected": ">= 2.0.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["cobbler", "cwe-732", "package", "provisioning", "python", "self-hosted"]
not_affected_if: ["api-not-network-reachable"]
published_at: "2018-08-20T20:29:01+00:00"
first_seen_at: "2026-10-27T16:20:27+00:00"
updated_at: "2026-10-27T16:33:07+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-f88q-22g8-frcg", "first_seen_at": "2026-10-27T16:20:27+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2018-1000226", "first_seen_at": "2026-10-27T16:33:07+00:00"}]
---

# Cobbler Improper Validation of Security Tokens

Cobbler's XMLRPC API at /cobbler_api does not properly validate security tokens, so a network attacker can act with more privilege than granted. The sources say this can lead to privilege escalation, data manipulation or exfiltration, and harvesting of LDAP credentials.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:cobbler affected <= 2.6.11 fixed 3.0.0
- vendor:cobblerd cobbler affected >= 2.0.0 fixed ?

## How to check

- Check the installed Cobbler version with `cobbler version` or `pip show cobbler`, and treat anything at or below `2.6.11` as affected.
- Confirm whether the XMLRPC API is reachable from the network, for example by looking for the `/cobbler_api` endpoint on the Cobbler web server.

## Fix

- Upgrade Cobbler to `3.0.0` or later, the fixed version named in the advisory.
- If an upgrade is not possible right away, unknown whether the sources list a workaround; restrict network access to `/cobbler_api`.

## Timeline

- 2026-10-27T16:20:27+00:00 ghsa https://github.com/advisories/GHSA-f88q-22g8-frcg
- 2026-10-27T16:33:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2018-1000226

## From the sources

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
