{"id":"CVE-2018-1000226","kind":"vulnerability","aliases":["CVE-2018-1000226","GHSA-f88q-22g8-frcg"],"related":[],"title":"Cobbler Improper Validation of Security Tokens","description":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via \"network connectivity\". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.","summary":"Cobbler's XMLRPC API at /cobbler_api does not properly validate security tokens, so a network attacker can act with more privilege than granted. The sources say this can lead to privilege escalation, data manipulation or exfiltration, and harvesting of LDAP credentials.","severity":"critical","cvss":9.8,"epss":0.12584,"exploited":false,"exploited_at":null,"products":[{"name":"cobbler","fixed":["3.0.0"],"affected":"<= 2.6.11","ecosystem":"pypi"},{"name":"cobblerd cobbler","fixed":[],"affected":">= 2.0.0","ecosystem":"vendor"}],"ecosystems":["pypi","vendor"],"tags":["cobbler","cwe-732","package","provisioning","python","self-hosted"],"not_affected_if":["api-not-network-reachable"],"how_to_check":"- Check the installed Cobbler version with `cobbler version` or `pip show cobbler`, and treat anything at or below `2.6.11` as affected.\n- Confirm whether the XMLRPC API is reachable from the network, for example by looking for the `/cobbler_api` endpoint on the Cobbler web server.","fix":"- Upgrade Cobbler to `3.0.0` or later, the fixed version named in the advisory.\n- If an upgrade is not possible right away, unknown whether the sources list a workaround; restrict network access to `/cobbler_api`.","status":"open","published_at":"2018-08-20T20:29:01+00:00","first_seen_at":"2026-10-27T16:20:27+00:00","triaged_at":"2026-10-27T16:21:28+00:00","updated_at":"2026-10-27T16:33:07+00:00","category":"package","confidence":0.8,"triage":{"at":"2026-10-27T16:21:28Z","model":"claude-haiku-5-5","output":{"fix":"- Upgrade Cobbler to `3.0.0` or later, the fixed version named in the advisory.\n- If an upgrade is not possible right away, unknown whether the sources list a workaround; restrict network access to `/cobbler_api`.","reach":"network","title":"Cobbler: improper token validation in XMLRPC API allows privilege escalation","impact":"high","summary":"Cobbler's XMLRPC API at /cobbler_api does not properly validate security tokens, so a network attacker can act with more privilege than granted. The sources say this can lead to privilege escalation, data manipulation or exfiltration, and harvesting of LDAP credentials.","category":"package","nicknames":[],"who_cares":["cobbler","self-hosted","python","provisioning"],"confidence":0.8,"needs_auth":"unknown","worst_case":"Attacker escalates privileges, alters or exfiltrates data, and harvests LDAP credentials.","analyst_note":"Confirm the exact affected version range and whether any workaround exists; the advisory at https://github.com/advisories/GHSA-f88q-22g8-frcg is the place to check.","how_to_check":"- Check the installed Cobbler version with `cobbler version` or `pip show cobbler`, and treat anything at or below `2.6.11` as affected.\n- Confirm whether the XMLRPC API is reachable from the network, for example by looking for the `/cobbler_api` endpoint on the Cobbler web server.","needs_analyst":true,"not_affected_if":["api-not-network-reachable"],"who_is_affected":"Teams that run Cobbler as a provisioning server with its XMLRPC API reachable over the network are exposed. The advisory notes that older versions than 2.6.11 may also be affected, so the exposure window is not fully bounded. Installations where the API is not reachable from untrusted networks are less exposed.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"critical"},"cost_usd":0.000685,"input_tokens":3446,"output_tokens":680,"severity_before":"critical"},"analyst_status":null,"analyst_note":null,"search":"'-1000226':9A,17A '-10931':148C '-2018':8A,16A,147C '-732':23B '/cobbler_api':35B,104C '2.0.0':86C '2.6.11':79C '22g8':13A 'access':98C 'act':47B 'advantag':128C 'api':33B,103C,136C 'appear':120C 'attack':45B,119C 'cobbler':1A,18A,20A,21B,30B,71C,77C 'cobblerd':19A 'code':81C 'connect':126C 'contain':95C 'control':99C 'credenti':70B,116C 'cve':7A,15A,146C 'cwe':22B 'data':62B,111C 'differ':143C 'endpoint':137C 'escal':61B,110C 'even':89C 'exfiltr':65B,114C 'exploit':123C 'f88q':12A 'frcg':14A 'ghsa':11A 'ghsa-f88q-22g8-frcg':10A 'grant':52B 'harvest':67B,117C 'host':29B 'improp':2A,130C 'incorrect':97C 'inspect':82C 'issu':144C 'ldap':69B,115C 'lead':58B 'least':85C 'manipul':63B,112C 'may':92C 'network':44B,125C 'note':139C 'older':90C 'packag':24B 'pleas':138C 'possibl':88C 'present':75C 'privileg':50B,60B,109C 'proper':38B 'provis':25B 'python':26B 'result':107C 'say':55B 'secur':5A,40B,133C 'self':28B 'self-host':27B 'sourc':54B 'suggest':83C 'take':127C 'token':6A,41B,134C 'valid':3A,39B,131C 'verifi':73C 'version':72C,78C,91C 'via':124C 'vulner':94C,100C 'xmlrpc':32B,102C","nicknames":[],"mitigations":[],"who_affected":"Teams that run Cobbler as a provisioning server with its XMLRPC API reachable over the network are exposed. The advisory notes that older versions than 2.6.11 may also be affected, so the exposure window is not fully bounded. Installations where the API is not reachable from untrusted networks are less exposed.","tier":"B","verified":{},"analyst_revisit_at":null,"first_public_at":"2018-08-20T20:29:01+00:00","kev":null,"cvss_vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvss_by":"GitHub","poc_count":0,"sources":[{"source":"ghsa","external_id":"GHSA-f88q-22g8-frcg","url":"https://github.com/advisories/GHSA-f88q-22g8-frcg","severity":"critical","published_at":"2022-05-13T01:48:35+00:00","modified_at":"2026-10-27T16:17:26+00:00","first_seen_at":"2026-10-27T16:20:27+00:00","fetched_at":"2026-10-27T16:20:27+00:00","note":null},{"source":"nvd","external_id":"CVE-2018-1000226","url":"https://nvd.nist.gov/vuln/detail/CVE-2018-1000226","severity":null,"published_at":"2018-08-20T20:29:01+00:00","modified_at":"2026-06-17T01:32:43+00:00","first_seen_at":"2026-10-27T16:33:07+00:00","fetched_at":"2026-10-27T16:33:07+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}